What devices is SPRK+ compatible with?

Updated 1 month ago by mike moran

SPRK+ works with many BLE iOS, Android, Kindle devices, Chromebook Specific operating systems and device requirements are as follows:

iOS

Device ModelOS Version
iPad 3+iOS10+
iPhone 4S+iOS 10+
iPod Touch 5th Generation +iOS 10+

Android

Android devices, while having OS 4.4.2 or higher, must have all of the following hardware in order to operate with BB-8:

  • Bluetooth LE (4.0)
  • Microphone
  • Distinct multi-touch landscape touchscreen
  • Hardware sensors including gyroscope and accelerometer
  • WiFi capabilities

Kindle 

Device ModelOS Version
Kindle Fire (2015)
Fire OS 5.0+
Fire HD 6
Fire OS 5.0+
Fire HD 8
Fire OS 5.0+
Fire HD 10    
Fire OS 5.0+


Chrome -- only available through the Sphero Edu Chrome app: Requires Chrome 50+, but robots will only connect on Chrome OS.  We are working hard to support robot connectivity on Windows and Apple computers in the future.


How did we do?