Sphero Edu Compatibility Details

Updated 4 weeks ago by mike moran

Programming Devices Compatibility

iOS: iOS 10+ (iPad 2 only works with Bluetooth Classic Devices: Sphero 2.0 & Sphero SPRK)

Android: Android 4.4+

Kindle: Kindle Fire (2015), Fire HD 6, Fire 7, Fire HD 8 or Fire HD 10

Chromebook: Chrome 50+ (robots connect on Chrome OS, not on Windows or Mac)

Mac: OSX 10.12+ (Sierra)

Windows: Coming in Fall 2018! Will work with Windows 10 v1703+ (Creators Update)


Platforms

Features

iOS/Android/Kindle  Chrome OS
Mac OSWebsite
Driving



Programming (Draw/Blocks/Text)


Program Camera



Activities



Localized to 14 Languages

Sensor Data Stream



Sensor Data Archive



Assignment Progress/Review



Activity Authoring



Class Management



The Robots

Supported

Sphero SPRK+, Sphero SPRK, Sphero 2.0, Sphero Mini, Ollie, BB-8, BB-9E, R2-D2, R2-Q5

Unsupported

Sphero Original, Force Band, Lightning McQueen, and Spider-Man 

Languages

Arabic, Chinese (Simplified), Chinese(Traditional), English, French, German, Hebrew, Italian, Japanese, Korean, Norwegian, Spanish (Mexico), Spanish (Spain), Swedish

------------------------------------------------------------------------------------------------------------------

A word from the creators of Sphero

We have hacked, modded and manipulated nearly every piece of hardware we have owned. That being said, we know some customers have done the same. We are working very hard to support as many devices and software versions as we can, but if you have a custom ROM for your Android device or a jailbroken iPhone you may experience issues that we have not accounted for in the public release.


How did we do?