Major Sphero Edu macOS App Update

Micah Daby Updated by Micah Daby

The 6.3.4 release of Sphero Edu for macOS utilizes new technology to bring the user experience into alignment with those found on our iOS and iPad apps. Our goal with 6.3.4 is to ensure feature parity across the various versions of Sphero Edu on all Apple platforms, and to ensure that we have a technical foundation to provide more frequent improvements in the future.

Q: What's Different Between the 6.3.4 macOS App and Older Versions?

There are a handful of benefits to using the new 6.3.4 version of Sphero Edu on macOS:

Feature

6.3.4 Sphero Edu App for macOS

Older Versions of Sphero Edu App for macOS

Supports firmware updates for all compatible robots

Yes

No*

Allows for offline usage (can program without the internet)

Yes

No (requires internet at all times)

Has guest mode and local storage of programs

Yes

No (requires an account to program and access work at all times)

Live streaming of robot sensor data while programming

Yes

No

Robust classroom view for class code users

Yes

No

Accurate localization (app translations)

Yes

No

* Older versions of Sphero Edu on macOS have very limited firmware update support (only supports SPRK, SPRK+, BB-8, Sphero 2.0, and Ollie).

There are a few things that teachers and parents must do on the Sphero Edu website, as they are not supported in the 6.3.4 macOS version of Sphero Edu. This includes the following:

  • Class set up, management and assignment of activities
  • Creation of custom activities
  • Password or profile changes

In each of the above cases, the 6.3.4 app will open a browser to complete the needed work at edu.sphero.com.

The Sphero Edu 6.3.4 macOS release fixes an existing issue that impacts Google Sign-In on older versions of the macOS app. If you are experiencing the Google Sign-In issue that's described in this support document, please update to 6.3.4.

Q: What Are The Required Specs For Sphero Edu 6.3.4?

Due to new technical requirements, the Sphero Edu 6.3.4 macOS release is compatible with the following versions of macOS:

  • Catalina
  • Big Sur
  • Monterey (or newer)

Below is a list of OS versions that are no longer supported with the 6.3.4 release:

  • Mojave
  • High Sierra
  • Sierra
  • El Capitan

If you have not updated to macOS Catalina or newer, then we highly encourage you to do so. If you are currently unable to update your operating system, then you can still access the last supported version of the Sphero Edu macOS app that is compatible with your computer (version 5.3.3).

To manually update to the newest 6.3.4 version of Sphero Edu, please visit the Mac App Store page, located here.

Below is a list of Mac models that can update to Catalina or newer. If your device falls into one of these categories, you can update your operating system and install the Sphero Edu 6.3.4 macOS release.

iMac

Late 2012 or newer

Mac Pro

Late 2013 or newer

Mac Mini

Late 2012 or newer

MacBook

Early 2015 or newer

MacBook Air

Mid 2012 or newer

MacBook Pro

Mid 2012 or newer

iMac Pro

All

How did we do?

iOS Sphero Edu Video Playback Issues

Google Sign-In Changes for the macOS and Windows Versions of Sphero Edu (Legacy Issue)

Contact