Spider-Man Device Compatibility

Updated 6 months ago by Micah Daby

The Spider-Man app works with many iOS and Android mobile devices using Bluetooth Low Energy (BLE 4.0).  Specific operating systems and device requirements are as follows:

iOS:

Device Model

OS Version

iPad 3+

iOS 9+

iPad Mini 2+

iOS 9+

iPhone 5S+

iOS 9+

iPod Touch 6th Generation+

iOS 9+


Android:

A compatible device running Android 4.3 to Android 9.0 is required to run the Spider-Man Interactive App-Enabled Super Hero application. Android devices must also have the following hardware support in order to use all features:

  • Bluetooth LE (4.0)
  • Touchscreen
  • WiFi capabilities
Note: Android 10 is not supported with the Spider-Man Interactive App-Enabled Super Hero application. The app will not connect to Spider-Man via Bluetooth correctly with an Android device running Android 10.
A word from the creators of Sphero:
We have hacked, modded and manipulated nearly every piece of hardware we have owned. That being said, we know some customers have done the same. We are working very hard to support as many devices and software versions as we can, but if you have a custom ROM for your Android device or a jailbroken iPhone you may experience issues that we have not accounted for in the public release.


How did we do?


Powered by HelpDocs (opens in a new tab)