Our SPRK Edition robot has the same compatibility requirements as our Sphero 2.0 robot. Check out those compatibility specs here. These compatibility requirements are not to be confused with those of our SPRK+ robot. 


Another important note, our Sphero Edu app requires a different set of specifications to download and use that platform. Check your device's compatibility if you wish to use your SPRK Edition with our Sphero Edu app.


If you have any questions or concerns, please follow the link to open a new support ticket.





Or feel free to contact us at your convenience:

1-888-977-4376

Email: support@sphero.com