All of our Sphero products work with Android devices. Yet given the vastness of the Android platform, devices must at least meet the specifications below to work with our products: 


Spider-Man, Force Band, BB-8, Ollie, and SPRK+
Sphero, Sphero 2.0, and Sphero SPRK Edition
Ultimate Lightning McQueen, R2-D2, and BB-9E 
  • At least Android 4.4.2 or higher
  • Bluetooth LE (4.0)
  • Front and rear-facing cameras
  • Microphone
  • Distinct multi-touch landscape touchscreen
  • Hardware sensors including gyroscope and accelerometer
  • WiFi capabilities
  • At least Android 4.4.2 or higher
  • Bluetooth
  • Front and rear-facing cameras
  • Microphone
  • Distinct multi-touch landscape touchscreen
  • Hardware sensors including gyroscope and accelerometer
  • WiFi capabilities
  • At least Android 5.0 or higher
  • Bluetooth LE (4.0)
  • Front and rear-facing cameras
  • Microphone
  • Distinct multi-touch landscape touchscreen
  • WiFi capabilities


If your Android device does not meet the device specifications, the application for your respective Sphero product will not appear on the Google Play store for download. 






Not what you were looking for? Check out our individual product compatibility pages: 

Force Band      BB-8      Sphero      SPRK Edition      Ollie      SPRK+      Lightning McQueen      Spider-Man      Droids App